笔记

Ecshop安装过程中的的问题:cls_image::gd_version()和不支持JPEG

在安装Ecshop的时候,遇到两个问题:


  1.Strict Standards: Non-static method cls_image::gd_version() should not be called statically in  D:\X\www\ecshop\install\includes\lib_installer.php on line 31


  解决:找到install/includes/lib_installer.php中的第31行   return cls_image::gd_version();然后在找到include/cls_image.php中的678 行,发现gd_version()方法未声明静态static,所以会出错。这时候只要:

ningjian 2016-8-26 0评论

笔记

iframe框架调用高度自适应方法

<iframe frameborder="0" src="http://www.wtwlb.com/" class="iframe" frameborder="0" id="test" onload="this.height=100" width="762px"   scrolling="no"></iframe>
<script type="text/javascript">
function reinitIframe(){
var iframe = document.getElementById("test");
try{
var bHeight = iframe.contentWindow.document.body.scrollHeight;
var dHeight = iframe.contentWindow.document.documentElement.scrollHeight;
var height = Math.max(bHeight, dHeight);
iframe.height = height;
console.log(height);
}catch (ex){}
}
window.setInterval("reinitIframe()", 200);
</script>


ningjian 2016-8-26 0评论

笔记

帝国cms 下载不采用弹出窗口式的修改方法

如果不采用弹出式下载的话,可依以下步骤完成:

1.修改下载地址模板("公共模板" -> "修改下载地址模板"):

将:

[ <a href=#edown onclick="window.open('[!--down.url--]','','width=300,height=300');">[!--down.name--]</a> ]

改成:

[ <a href="/e/DownSys/GetDown?classid=2&id=54&pathid=[!--pathid--]">[!--down.name--]</a> ]

ningjian 2016-8-26 0评论